[vector-api][X86] Intrinsic creation for missing cases of iotaShuffle API
Vladimir Ivanov
vladimir.x.ivanov at oracle.com
Thu Nov 14 13:31:18 UTC 2019
> In loopTransform.cpp I would encourage you to make your change more incremental.
> Your change re-orders the existing predicate terms while inserting the new term at the
> beginning. It is more conventional to add new logic at the end, while retaining the flow
> of the old logic. I think breaking the lines *is* a good idea, so something like this is good:
>
> - if (opc == Op_StoreP || opc == Op_StoreN || opc == Op_StoreNKlass || opc == Op_StoreCM) {
> +- if (opc == Op_StoreVector || opc == Op_StoreP ||
> ++ if (opc == Op_StoreP ||
> + opc == Op_StoreN || opc == Op_StoreNKlass ||
> +- opc == Op_StoreCM) {
> ++ opc == Op_StoreCM || opc == Op_StoreVector) {
Also, Jatin, please, clarify what was the motivation to do this change
in the first place.
> You can still use two lambdas if you want for the fallback, one for each value
> of wrap. But I suspect using one would be cleaner.
>
> (I’ll defer to Vladimir on this; he may have more information about what’s right here.)
From compiler perspective it doesn't matter. So, I'd vote for the
option which makes the code more readable.
Best regards,
Vladimir Ivanov
More information about the panama-dev
mailing list