[vector] Min/Max support cleanup for x86
John Rose
john.r.rose at oracle.com
Fri Feb 7 22:10:02 UTC 2020
On Feb 3, 2020, at 1:52 PM, Viswanathan, Sandhya <sandhya.viswanathan at intel.com> wrote:
>
>
> Please find below a webrev which attempts to clean up the Min/Max support in x86.ad file.
>
> http://cr.openjdk.java.net/~sviswanathan/vectorIntrinsics/MinMaxCleanup/webrev.00 <http://cr.openjdk.java.net/~sviswanathan/vectorIntrinsics/MinMaxCleanup/webrev.00>
>
Very nice refactoring. This bit is the best news:
> 616 lines changed: 69 ins; 481 del; 66 mod; 22624 unchg
Removing lines of code is a fine way to prevent bugs.
I like the API shape of MacroAssembler::vpminmax,
although it seems a single step from separate min and max
and several steps from a macro that handles a larger number
of ops. I wonder where the sweet spot is. (No action required
here.)
The macro assembler seems to say both “min_max” and “minimal”.
I suggest picking just convention and sticking with it.
FWIW I think “minmax” is easier to read
(That may be because I’m dreaming here of replacing “minmax” by
“lanewise” with a richer operation parameter. :-)
— John
More information about the panama-dev
mailing list