[vectorIntrinsics] RFR: 8259536: Add cast nodes between interger types implementation for Arm SVE [v5]

Wang Huang whuang at openjdk.java.net
Tue Feb 2 12:55:57 UTC 2021


On Fri, 29 Jan 2021 02:48:35 GMT, Ningsheng Jian <njian at openjdk.org> wrote:

>> Wang Huang has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains six commits:
>> 
>>  - Merge vectorIntrinsics
>>  - remove useless codes
>>  - remove walkaround codes
>>  - add other I2I cast nodes
>>  - fix build bug on other archs caused by UseSVE > 0
>>  - 8259536: Add cast nodes between interger types implementation for Arm SVE
>
> src/hotspot/cpu/aarch64/aarch64_sve_ad.m4 line 1504:
> 
>> 1502: %{
>> 1503:   predicate(UseSVE > 0 && n->bottom_type()->is_vect()->length_in_bytes() >= 16 &&
>> 1504: 	    n->bottom_type()->is_vect()->element_basic_type() == T_`'TYPE2DATATYPE($2));
> 
> And here is another tab.

Thank you for your review. I have revised this.

> src/hotspot/cpu/aarch64/aarch64_sve_ad.m4 line 1460:
> 
>> 1458: // ------------------------------ Vector cast -------------------------------
>> 1459: dnl
>> 1460: define(`VECTOR_CAST_I2I', `
> 
> I think the I2I name is a bit confusing, as it is also used by S2I, I2L (though NEON has the same naming...). Maybe VECTOR_CAST_EXTEND?

Thank your for your advice.

-------------

PR: https://git.openjdk.java.net/panama-vector/pull/31


More information about the panama-dev mailing list