[foreign-memaccess+abi] RFR: 8270376: Finalize API for memory copy

Maurizio Cimadamore mcimadamore at openjdk.java.net
Tue Jul 13 18:23:31 UTC 2021


This patch ties up some loose ends with the MemoryCopy API, and it also prepares the ground for some other related refactorings in this area.

The meat of this patch is represented by the various changes in MemoryCopy, where all methods were renamed to simply `copy`, and the length parameter (now called `elementCount`) is always moved to the end.

I've also simplified naming of parameters, as I think distinguishing between `index` and `offset` is enough (e.g. an array has an index, a segment has an offset).

You will see that, at the very end of the class, three more copy methods have been added, which deal fully in terms of segments. I have also moved the complex layout-based memory segment copy operation (which does the swap) as a static method in this class, as I believe the static form makes the method more regular and usable.

I've made some changes to our uses of `copyFrom` in the linker, to use the new methods in `MemoryCopy` when the copy operation was performing slicing in the source/target segment, which I think makes the code more readable. Of course these changes are completely optional and could be omitted as well.

-------------

Commit messages:
 - Fix jaavdoc warning
 - Remove comments from StdLibTest
 - Initial push
 - Initial reshuffle/rename of copy methods

Changes: https://git.openjdk.java.net/panama-foreign/pull/568/files
 Webrev: https://webrevs.openjdk.java.net/?repo=panama-foreign&pr=568&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8270376
  Stats: 504 lines in 12 files changed: 106 ins; 108 del; 290 mod
  Patch: https://git.openjdk.java.net/panama-foreign/pull/568.diff
  Fetch: git fetch https://git.openjdk.java.net/panama-foreign pull/568/head:pull/568

PR: https://git.openjdk.java.net/panama-foreign/pull/568


More information about the panama-dev mailing list