Vector API review
Remi Forax
forax at univ-mlv.fr
Wed Mar 31 21:43:55 UTC 2021
Hi all,
next week i will do a lab on the vector API, so i've played a little more with the API.
There are still things to polish,
- IntVector.addIndex() should be addLaneIndex(int scale)
- Vector.lanewise should be Vector.apply given that test or conversion are also lanewise,
calling a function is usually "apply".
- While Vector.lanewise is overloaded for unary, binary, ternary and associative,
for unary test and binary test, we have two different name test and compare.
I think, compare should be renamed to test.
And VectorOperators.Test should be VectorOperators.UnaryTest and Comparison should be BinaryTest.
I still don't like Associative, it seems risky to have a type just for reduceLane.
What if in the future Intel, AMD, ARM or whatever decide that reduceLane can work with SUB ?
In term of javadoc, all the intergace like VectorOperations.Unary, Binary, etc should document all the possible operations,
instead we have to crawle VectorOperations looking for the right type.
There is no iota as a static method on IntVector, LongVector, etc, so we have to use zero().addIndex(1) which is weird
(or i've missed something ?)
- Having add, sub, etc on Vector is useless given that we already have lanewise().
Having add, etc, etc on the specialized version, IntVector, LongVector, is a better idea because the parameter type can be typed
with the right specialized type instead of Vector, e.g, IntVector.add(IntVector) instead of InteVector.add(Vector)
- Can wa agree that having a static method and an instance method with the same name like broadcast is not a good idea
I don't see the point of the instance method given that it replaces all the values.
- I aslo don't see the point of maskAll() given that it's species().maskAll()
- I don't see why convertShape is not named convert too given that convert also returns a vector with a different shape
- remove selectFrom() given that it's rearrange()
- I dont see the point of the reinterpretAsFoo, perhaps a reinterpretAs(Class<?>) is enough ?
- check() can renamed to "is"/"isInstance" because it's an instanceof test
Rémi
More information about the panama-dev
mailing list