[vectorIntrinsics+mask] RFR: 8272745: VectorAPI: Vector/Mask type cleanup for masked vector intrinsics
Eric Liu
eliu at openjdk.java.net
Wed Sep 1 01:32:25 UTC 2021
Some of the VectorAPIs were inconsistent with their intrinsic
declarations, and some of the type arguments were not precise enough as
well. E.g., The return type of "unaryOp" should be a subtype of "Vector"
instead of an all-purpose "Object" [1][2].
The imprecise declarations and type arguments would not effect the
correctness but bring bad readability and make the code hard to
maintain. This patch is a cleanup for those mismatched declarations of
VectorAPIs.
[1] https://github.com/openjdk/panama-vector/blob/vectorIntrinsics%2Bmask/src/java.base/share/classes/jdk/internal/vm/vector/VectorSupport.java#L269
[2] https://github.com/openjdk/panama-vector/blob/vectorIntrinsics%2Bmask/src/hotspot/share/classfile/vmIntrinsics.hpp#L812
-------------
Commit messages:
- 8272745: VectorAPI: Vector/Mask type cleanup for masked vector intrinsics
Changes: https://git.openjdk.java.net/panama-vector/pull/117/files
Webrev: https://webrevs.openjdk.java.net/?repo=panama-vector&pr=117&range=00
Issue: https://bugs.openjdk.java.net/browse/JDK-8272745
Stats: 250 lines in 4 files changed: 89 ins; 12 del; 149 mod
Patch: https://git.openjdk.java.net/panama-vector/pull/117.diff
Fetch: git fetch https://git.openjdk.java.net/panama-vector pull/117/head:pull/117
PR: https://git.openjdk.java.net/panama-vector/pull/117
More information about the panama-dev
mailing list