[foreign-memaccess+abi] RFR: 8275644: Replace VMReg in shuffling code with something more fine grained.

Jorn Vernee jvernee at openjdk.org
Wed Aug 10 12:16:57 UTC 2022


On Wed, 10 Aug 2022 12:01:00 GMT, Maurizio Cimadamore <mcimadamore at openjdk.org> wrote:

>> I can add some comments to the fields. What do you mean by 'uniform naming scheme'?
>
>> I can add some comments to the fields. What do you mean by 'uniform naming scheme'?
> 
> Sorry, I meant that one field is called `segmentMaskOrSize` but the other is just called `index`. Using `or` on both might be a good idea.

Ah, ok. That sounds good.

-------------

PR: https://git.openjdk.org/panama-foreign/pull/699


More information about the panama-dev mailing list