[vectorIntrinsics] RFR: 8305461: [vectorapi] Add VectorMask::xor, rename VectorMask::eq to VectorMask::xorNot
Paul Sandoz
psandoz at openjdk.org
Mon Apr 3 15:19:47 UTC 2023
On Mon, 3 Apr 2023 13:40:33 GMT, Quan Anh Mai <qamai at openjdk.org> wrote:
> Hi,
>
> This patch adds `VectorMask::xor` to the public API, as well as renames `VectorMask::eq` to `VectorMask::xorNot` for consistency with other logical operations. I also add unit tests for all logical vector operations to `test/jdk/jdk/incubator/vector`. Please kindly review and give your opinions on this change.
>
> Thanks a lot.
The addition of `xor` looks good.
I have mixed feelings about changing `eq` to `xorNot`. I understand the motivation, but I think it will cause confusion and make code harder to read. The documentation clearly states the logical relationship and intuitively its easy to think of this as boolean equivalence on the lanes, as in `a == b`.
Given this change is not a large architectural change that requires some time to soak let's do this change in the main repo with a CSR. Are you ok with that? If need be i can help with the CSR.
-------------
PR Review: https://git.openjdk.org/panama-vector/pull/212#pullrequestreview-1369260683
More information about the panama-dev
mailing list