[foreign-memaccess+abi] RFR: 8301801: Implement arena-centric API [v3]
Jorn Vernee
jvernee at openjdk.org
Fri Feb 10 15:05:22 UTC 2023
On Fri, 10 Feb 2023 11:40:36 GMT, Maurizio Cimadamore <mcimadamore at openjdk.org> wrote:
>> This patch implements the API proposal described here:
>>
>> https://cr.openjdk.java.net/~mcimadamore/panama/scoped_arenas.html
>>
>> The main changes are:
>>
>> * Static factories `MemorySegment::allocateNative` are gone;
>> * The static factory `SegmentAllocator::nativeAllocator` is also gone;
>> * `SegmentScope` moved as nested class in `MemorySegment` (e.g. `MemorySegment.Scope`);
>> * Tweak methods accepting `SegmentScope` to accept `Arena` instead;
>> * Simplify `Arena` API, by removing predicates (`isCloseable`/`isAccessibleBy`) and by dropping `whileAlive`;
>> * Change arena factories to use `of` prefix instead of `open` - and rename `auto()` to `ofAuto()`.
>>
>> The API changes are rather straightforward, but they lead to several shallow test and microbenchmark changes, so the number of affected file is quite big (mostly because of the rename `openConfined` -> `ofConfined`).
>>
>> A javadoc of the proposed changes is available here:
>>
>> http://cr.openjdk.java.net/~mcimadamore/panama/scoped_arena_interface_lump_predicates/
>
> Maurizio Cimadamore has updated the pull request incrementally with one additional commit since the last revision:
>
> Address review comments
test/micro/org/openjdk/bench/java/lang/foreign/BulkOps.java line 66:
> 64:
> 65: final long unsafe_addr = unsafe.allocateMemory(ALLOC_SIZE);
> 66: final MemorySegment segment = arena.allocate(ALLOC_SIZE, 1);
Thanks for cleaning this up. There are still 2 more instances of this in the same file.
-------------
PR: https://git.openjdk.org/panama-foreign/pull/781
More information about the panama-dev
mailing list