RFR(S): 8028514: PPC64: Fix C++ Interpreter after '7195622: CheckUnhandledOops has limited usefulness now'

David Holmes david.holmes at oracle.com
Tue Nov 19 11:11:44 PST 2013


Thanks Volker - nothing further from me.

David

On 19/11/2013 8:08 PM, Volker Simonis wrote:
> Hi Lois,
>
> thanks for your review. Here's the new webrev:
>
> http://cr.openjdk.java.net/~simonis/webrevs/8028514.v2/
>
> Please find my comments inline:
>
> On Tue, Nov 19, 2013 at 3:35 AM, Lois Foltan <lois.foltan at oracle.com> wrote:
>> Hi Volker,
>>
>> I do have a few review comments:
>>
>>    src/cpu/ppc/vm/frame_ppc.cpp
>>      - The "cast_to_oop<void *>(NULL)" I believe could be simplified to
>> "(oop)NULL" see similar code in
>>         src/cpu/x86/vm/frame_x86.cpp.
>>
>
> I was not sure here and wanted to make the conversion explicit,
> because NULL is actually the integer constant 'zero' and there's no
> special oop constructor for integers. But if the compiler doesn't
> complain and if it works on x86 I can change it as you suggested.
>
>>    src/share/vm/interpreter/bytecodeInterpreter.cpp
>>      - I have attached the recent RFR for supporting CHECK_UNHANDLED_OOPS
>> across the platforms.
>>        It contains the summary outlining the changes.  Please change your
>> "cast_from_oop<uintptr_t>"
>>        within tty->print_cr() to "(void *)" as described in summary note item
>> #3.
>
> You're right, I missed the (void*)operator in the oop class. I changed
> it the way you suggested.
>
> Thanks,
> Volker
>
>>
>> Thank you,
>> Lois
>>
>>
>> On 11/18/2013 11:45 AM, Volker Simonis wrote:
>>>
>>> Hi,
>>>
>>> could you please review the following small webrev which fixes the
>>> CPP-interpreter after "CheckUnhandledOops" was re-enabled in the
>>> fastdebug build:
>>>
>>> http://cr.openjdk.java.net/~simonis/webrevs/8028514/
>>>
>>> All the changes are in CPP-interpreter specific files or in code which
>>> is protected by "#ifdef  CC_INTERP". Most changes just switch
>>> old-style "(oop)"casts to new-style "cast_to_oop()" conversions.
>>>
>>> Thank you and best regards,
>>> Volker
>>
>>


More information about the ppc-aix-port-dev mailing list