[riscv-port] RFR: 8279292: riscv: Intrinsify multiplyToLen and squareToLen [v2]

Feilong Jiang fjiang at openjdk.java.net
Mon Dec 27 12:22:26 UTC 2021


On Mon, 27 Dec 2021 11:26:48 GMT, Fei Yang <fyang at openjdk.org> wrote:

>> Feilong Jiang has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   fix type and code renaming
>
> src/hotspot/cpu/riscv/macroAssembler_riscv.cpp line 3249:
> 
>> 3247: 
>> 3248: /**
>> 3249:  * Multiply 128 bit by 128. Unrolled inner loop.
> 
> Should be: "Multiply 128 bit by 128 bit. Unrolled inner loop."

Fixed.

> src/hotspot/cpu/riscv/macroAssembler_riscv.cpp line 3381:
> 
>> 3379: 
>> 3380: /**
>> 3381:  * Code for BigInteger::multiplyToLen() instrinsic.
> 
> There is a typo here. Should be: ""Code for BigInteger::multiplyToLen() intrinsic."

Fixed.

> src/hotspot/cpu/riscv/macroAssembler_riscv.cpp line 3417:
> 
>> 3415:   mv(carry, zr); // carry = 0;
>> 3416: 
>> 3417:   Label L_multiply_64_or_128, L_done;
> 
> Suggestion: rename L_multiply_64_or_128 into L_multiply_64_x_64_loop

Thanks for the suggestion, renamed.

> src/hotspot/cpu/riscv/macroAssembler_riscv.cpp line 3424:
> 
>> 3422:   const Register jdx = tmp1;
>> 3423: 
>> 3424:   // if x and y are both 8 bytes aligend.
> 
> There is a typo here. Maybe "// Check if x and y are both 8-byte aligned."

Oops! Fixed.

-------------

PR: https://git.openjdk.java.net/riscv-port/pull/38


More information about the riscv-port-dev mailing list