<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
<br>
Mostly are fine, just a few comments:<br>
<br>
1) the convention is to place the regression tests based on the
provider which they are for, e.g.<br>
SunJCE provider -> com/sun/crypto/provider<br>
SUN provider -> sun/security/provider<br>
SunEC provider -> sun/security/ec<br>
Given that there is not a lot of dependency between these tests, can
u place them into the sub-directories under the dedicated path?<br>
The utility class <font color="#000000">TestSignatureOidHelper.java</font>
into can be placed under sun/security.<br>
<br>
2) several tests has "...must be failed", probably should be changed
to "...should fail"<br>
<br>
3) the variable naming seems confusing, e.g. cipherAlgorithm and
cipherOid both refer to Cipher objects while cipherText refers to
encrypted text. For future development, u may want to name the
cipher variables differently so it's obvious that they represent
Cipher objects.<br>
<br>
Thanks,<br>
Valerie<br>
<br>
On 8/13/2015 1:43 AM, Sha Jiang wrote:
<blockquote cite="mid:55CC58AF.7080608@oracle.com" type="cite">Hi
Security developers,
<br>
I have a security test bug
<a class="moz-txt-link-freetext" href="https://bugs.openjdk.java.net/browse/JDK-8075286">https://bugs.openjdk.java.net/browse/JDK-8075286</a>, which adds more
cases for NSA Suite B algorithms in jdk repo.
<br>
Please review this patch at
<a class="moz-txt-link-freetext" href="http://cr.openjdk.java.net/~fyuan/jjiang/8075286/webrev.00/">http://cr.openjdk.java.net/~fyuan/jjiang/8075286/webrev.00/</a>
<br>
Every comment is appreciated.
<br>
<br>
Best Regards,
<br>
John Jiang
<br>
</blockquote>
</body>
</html>