hg: jdk7/tl/jdk: 6860431: Character.isSurrogate(char ch)
Ulf Zibis
Ulf.Zibis at gmx.de
Tue Sep 1 01:29:53 PDT 2009
Martin,
I like how you have enhanced javadoc for Character class.
Some coments:
- You more like uppercased hex literals, so we are 2. :-)
- you have mixed <code>value</code> and {@code value}. I more like the
latter, it's compact and better readable
- you have mixed U+1234 and \u1234 style. Why?
- often you use '\' for '\', but not ever (e.g. '\t'). I think we
can use always '\'. There should not be so much developers in the world
who can't decode ISO-8859-1 or UTF-xx.
(aren't there many places in the JDK's javadoc where others have used
ISO-8859-1 characters ?)
- there are many "Character#xYz" or even "java.lang.Character#xYz" or "
"java.lang.Abc#xYz" " links left. They could be truncated for better
readability and smaller source size
- I would like to see backwards-referring like:
public static final int MIN_CODE_POINT = MIN_VALUE;
public static final int MIN_SUPPLEMENTARY_CODE_POINT = MAX_VALUE + 1;
-Ulf
Am 01.09.2009 00:11, martinrb at google.com schrieb:
> Changeset: db5d6b4cbc11
> Author: martin
> Date: 2009-08-31 15:00 -0700
> URL: http://hg.openjdk.java.net/jdk7/tl/jdk/rev/db5d6b4cbc11
>
> 6860431: Character.isSurrogate(char ch)
> Summary: Add new method Character.isSurrogate(char ch)
> Reviewed-by: sherman, darcy, okutsu
>
>
More information about the serviceability-dev
mailing list