RFR (S) 8007142: Add utility classes for writing better multiprocess tests in jtreg
Yekaterina Kantserova
yekaterina.kantserova at oracle.com
Tue Feb 5 02:51:32 PST 2013
On 02/04/2013 02:18 PM, Alan Bateman wrote:
> On 04/02/2013 11:03, Yekaterina Kantserova wrote:
>>
>> But JDKToolFinder.getJDKTool is used even for finding java, e.g. I
>> need to fork a java process - JDKToolFinder.getJDKTool("java") for
>> some JRE tests?
> It might be better to rename JDKToolFinder to something like JdkFinder
> and have it define getJavaLauncher() and getTool(String tool) methods.
I think it's good idea to separate java launcher and tools. Here is the
new JdkFinder:
http://cr.openjdk.java.net/~ykantser/8007142/webrev.02/test/lib/testlibrary/jdk/testlibrary/JdkFinder.java.html.
It now possible to retrieve java/tools both from the test.jdk and
compile.jdk.
> If you don't agree then you could at least change
> ProcessTools.createJavaProcessBuilder so that it looks like "java" in
> the JDK/JRE under test.
>
JDKToolFinder.getJDKTool("java") became JdkFinder.getJavaLauncher in
the createJavaProcessBuilder
(http://cr.openjdk.java.net/~ykantser/8007142/webrev.02/test/lib/testlibrary/jdk/testlibrary/ProcessTools.java.html).
> -Alan.
Thanks,
Katja
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/serviceability-dev/attachments/20130205/42334f0b/attachment-0001.html
More information about the serviceability-dev
mailing list