RFR: JDK-7107013: sun.jvm.hotspot.runtime.Bytes.swapLong conversion to long mishandled
Sharath Ballal
sharath.ballal at oracle.com
Thu Nov 10 08:30:30 UTC 2016
Hello Bernd,
For int also its “low 2 bytes | high 2 bytes” and again these two byte pairs are swapped by the swapshort as “lowbyte | highbyte”
Similarly for long its “ low 4 bytes | high 4 bytes” and again these pairs are swapped recursively.
So for int if the little endian byte order was 3 2 1 0 it is now converted to 0 1 2 3 and similarly for long.
-Sharath Ballal
From: Bernd Eckenfels [mailto:ecki at zusammenkunft.net]
Sent: Thursday, November 10, 2016 1:20 PM
To: serviceability-dev at openjdk.java.net; Dmitry Samersoff; Sharath Ballal
Subject: Re: RFR: JDK-7107013: sun.jvm.hotspot.runtime.Bytes.swapLong conversion to long mishandled
Hello,
Is the a reason why swapShort has a " lowbyte | highbyyte" and the other two methods the other way around? I would all write in the natural order of. Igendianess (I.e. Change the first).
Gruss
Bernd
--
http://bernd.eckenfels.net
On Thu, Nov 10, 2016 at 8:32 AM +0100, "Sharath Ballal" <HYPERLINK "mailto:sharath.ballal at oracle.com" \nsharath.ballal at oracle.com> wrote:
Thanks Dmitry. I have made the changes in line 54.
http://cr.openjdk.java.net/~sballal/7107013/webrev.01/
I didn't change the recursive calls to swap functions because that looks more readable.
-Sharath Ballal
-----Original Message-----
From: Dmitry Samersoff
Sent: Thursday, November 10, 2016 12:46 AM
To: Sharath Ballal; HYPERLINK "mailto:serviceability-dev at openjdk.java.net"serviceability-dev at openjdk.java.net
Subject: Re: RFR: JDK-7107013: sun.jvm.hotspot.runtime.Bytes.swapLong conversion to long mishandled
Sharath,
Please, add (int) to ll. 54 for better readability.
PS:
Despite the fact that C2 does a great job eliminating useless code (multiple calls to if (!swap) in this case) it would be nice to use simple, well known arithmetic directly instead of subsequent calls to other swap functions.
-Dmitry
On 2016-11-09 19:30, Sharath Ballal wrote:
> Hello,
>
> Pls review this small fix
>
>
>
> Issue: https://bugs.openjdk.java.net/browse/JDK-7107013
>
> Webrev: http://cr.openjdk.java.net/~sballal/7107013/webrev.00/
>
>
>
>
>
> -Sharath Ballal
>
>
>
>
>
--
Dmitry Samersoff
Oracle Java development team, Saint Petersburg, Russia
* I would love to change the world, but they won't give me the sources.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/serviceability-dev/attachments/20161110/5ddf9ca9/attachment-0001.html>
More information about the serviceability-dev
mailing list