RFR : JDK-8044122 MBean access to the PID

Roger Riggs Roger.Riggs at Oracle.com
Tue Oct 10 17:55:08 UTC 2017


Hi Ujwal,

In the implementation RuntimeMXBean.java: 72:  Include a message 
"getProcessId" in the throw new Unsupported...
In the text and @return change "PID" to "process ID" as Alan suggested.
66: the @implSpec should be on its own line so the text starts on a new 
line to make the source more readable.

Adding a test for getProcessId() should fit into one of the existing 
tests that spawns and then checks
the attributes of a vm.  Perhaps MXBeanInteropTest1.java

Roger



On 10/10/2017 1:20 PM, mandy chung wrote:
>
>
> On 10/10/17 4:47 AM, Ujwal Vangapally wrote:
>> Kindly review the changes made.
>>
>> https://bugs.openjdk.java.net/browse/JDK-8044122
>>
>> webrev : 
>> http://cr.openjdk.java.net/~uvangapally/webrev/2017/8044122/webrev.00/
>>
>
> RuntimeMXBean.java
>    @since is missing
>
>    Process::pid is long rather than int. The javadoc for this method 
> should be consistent with Process::pid, as Alan points out.
>
> VMManagementImpl.java
>     I think getProcessId should probably be replaced to implement with 
> ProcessHandle.current().pid();
>
> Please include an unit test for it.
>
> Mandy



More information about the serviceability-dev mailing list