RFR (S/T): 8231737: Cleanup JvmtiRawMonitor code

Per Liden per.liden at oracle.com
Tue Oct 8 06:56:34 UTC 2019


Hi David,

On 10/8/19 3:58 AM, David Holmes wrote:
> Bug: https://bugs.openjdk.java.net/browse/JDK-8231737
> webrev: http://cr.openjdk.java.net/~dholmes/8231737/webrev/
> 
> Stylistic code cleanup of JvmtiRawMonitor code as previously promised:

Very nice clean up! But when changing the names, may I suggest that we 
follow the HotSpot style-guide naming convention.

> - Self -> self
> - SimpleX -> simpleX

Should be simple_x

> - Contended -> contended
> - Node -> node
> - TState -> tState (variable name)

Should be _tstate or _t_state.

> - _WaitSet -> _waitSet

Should be _wait_set.

> - _EntryList -> _entryList;

Should be _entry_list.

cheers,
Per

> - All -> all
> - remove extra space before ( in function calls
> - remove extra space before ;
> - remove extra space before ++ and --
> - add spaces around binary operators
> - use { } on all blocks
> - use one statement per line.
> - fix indent and alignment (ie remove artificial alignment)
> 
> Probably simplest to look at new code and see if it looks okay rather 
> than trying to spot each individual change. :)
> 
> Thanks,
> David


More information about the serviceability-dev mailing list