RFR: 8253497: Core Libs Terminology Refresh [v2]

Alan Bateman alanb at openjdk.java.net
Tue Dec 15 07:36:57 UTC 2020


On Tue, 15 Dec 2020 01:46:08 GMT, Brent Christian <bchristi at openjdk.org> wrote:

>> This is part of an effort in the JDK to replace archaic/non-inclusive words with more neutral terms (see JDK-8253315 for details).
>> 
>> Here are the changes covering core libraries code and tests.  Terms were changed as follows:
>> 1. grandfathered -> legacy
>> 2. blacklist -> filter or reject
>> 3. whitelist -> allow or accept
>> 4. master -> coordinator
>> 5. slave -> worker
>> 
>> Addressing similar issues in upstream 3rd party code is out of scope of this PR.  Such changes will be picked up from their upstream sources.
>
> Brent Christian has updated the pull request incrementally with one additional commit since the last revision:
> 
>   updates, per code review

test/jdk/java/nio/channels/SocketChannel/CloseRegisteredChannel.java line 45:

> 43:         SocketChannel client = SocketChannel.open ();
> 44:         client.connect (new InetSocketAddress (InetAddress.getLoopbackAddress(), port));
> 45:         SocketChannel channel = server.accept ();

Can you rename this to "peer" instead? (we can remove the spurious space after accept while we are there).

-------------

PR: https://git.openjdk.java.net/jdk/pull/1771


More information about the serviceability-dev mailing list