RFR: 8289780: Avoid formatting stub names when Forte is not enabled [v2]

Serguei Spitsyn sspitsyn at openjdk.org
Fri Jul 8 22:58:41 UTC 2022


On Wed, 6 Jul 2022 17:50:54 GMT, Ioi Lam <iklam at openjdk.org> wrote:

>> `Forte::register_stub()` should be called only when the JVm is being instrumented by Forte (aka "Oracle Developer Studio")
>> 
>> https://www.oracle.com/tools/developerstudio/downloads/developer-studio-jsp.html
>> 
>> We currently always format the name of generated stubs and call `Forte::register_stub()`, which usually does nothing.
>> 
>> Example:
>> 
>> https://github.com/openjdk/jdk/blob/master/src/hotspot/share/runtime/sharedRuntime.cpp#L2686-L2697
>> 
>> To improve start-up, we should check if Forte is enabled before formatting the name.
>> 
>> I also renamed some `#ifndef IA64` around the code that I touched.
>
> Ioi Lam has updated the pull request incrementally with one additional commit since the last revision:
> 
>   Do not remove Forte::register_stub as it is used on Linux as well

I've posed one comment.
Other than that the fix looks okay.
Thanks,
Serguei

src/hotspot/share/runtime/sharedRuntime.cpp line 2700:

> 2698:     if (JvmtiExport::should_post_dynamic_code_generated()) {
> 2699:       JvmtiExport::post_dynamic_code_generated(blob_id, new_adapter->content_begin(), new_adapter->content_end());
> 2700:     }

The lines 2698-2670 is better to move out of the if-statement at the line 2687.

-------------

Marked as reviewed by sspitsyn (Reviewer).

PR: https://git.openjdk.org/jdk/pull/9386


More information about the serviceability-dev mailing list