RFR: 8287103: java/lang/management/ThreadMXBean/VirtualThreadDeadlocks.java fails with Xcomp
Alan Bateman
alanb at openjdk.java.net
Sat May 21 05:29:48 UTC 2022
On Fri, 20 May 2022 22:27:29 GMT, Leonid Mesnik <lmesnik at openjdk.org> wrote:
> Sync improved in test
test/jdk/java/lang/management/ThreadMXBean/VirtualThreadDeadlocks.java line 43:
> 41: private static final Object LOCK2 = new Object();
> 42:
> 43: private static volatile boolean lock2Obtained = false;
The term used in the APIs is "lock held" so might be better to rename this to lock2Held. Can you drop the explicit init to false and also put a blank line after the declaration as it looks strange to have it run into the comment on the main method.
-------------
PR: https://git.openjdk.java.net/jdk/pull/8821
More information about the serviceability-dev
mailing list