RFR: 8295303: cleanup debug agent's confusing use of EI_GC_FINISH [v3]
Chris Plummer
cjplummer at openjdk.org
Tue Nov 8 19:31:12 UTC 2022
On Tue, 8 Nov 2022 09:27:33 GMT, Serguei Spitsyn <sspitsyn at openjdk.org> wrote:
>> Chris Plummer has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains four commits:
>>
>> - merge
>> - Fixed ei range check logic errors.
>> - fix extra whitespace
>> - Rename EI_GC_FINISH to EI_CLASS_UNLOAD and other cleanups related to EI_GC_FINISH
>
> src/jdk.jdwp.agent/share/native/libjdwp/error_messages.c line 236:
>
>> 234: CASE_RETURN_TEXT(EI_CLASS_PREPARE)
>> 235: CASE_RETURN_TEXT(EI_CLASS_UNLOAD)
>> 236: CASE_RETURN_TEXT(EI_CLASS_LOAD)
>
> Nit: Would it be a little better to place it after EI_CLASS_UNLOAD?
If you mean put EI_CLASS_UNLOAD after EI_CLASS_LOAD, I tried to keep the current ordering. If you look in util.h (bottom of this page), it used to have:
EI_CLASS_PREPARE = 7,
EI_GC_FINISH = 8,
EI_CLASS_LOAD = 9,
and now it has:
```
EI_CLASS_PREPARE = 7,
EI_CLASS_UNLOAD = 8,
EI_CLASS_LOAD = 9,
There are a couple of other places where this ordering is preserved and I tried to be consistent.
-------------
PR: https://git.openjdk.org/jdk/pull/10887
More information about the serviceability-dev
mailing list