RFR: 8314502: GrowableArray: Make find with comparator take template

Johan Sjölen jsjolen at openjdk.org
Thu Aug 24 16:42:31 UTC 2023


On Thu, 24 Aug 2023 16:37:44 GMT, Johan Sjölen <jsjolen at openjdk.org> wrote:

>> The `find` method now is 
>> ```C++
>> template<typename T>
>> int find(T* token, bool f(T*, E)) const {
>> ...
>> 
>> Any other functions which use this are also changed.
>> Local linux-x64-debug hotspot:tier1 passed. Mach5 tier1 build on linux and Windows passed.
>
> src/hotspot/share/prims/jvmtiImpl.cpp line 126:
> 
>> 124:   assert(e2 != nullptr, "e2 != nullptr");
>> 125: 
>> 126:   return v->equals(e2);
> 
> Please rename the `v` parameter to `e1`

And since you're here: Could you change the code style so that it's `GrowableElement* e2` and not `GrowableElement *e2`?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/15418#discussion_r1304601987


More information about the serviceability-dev mailing list