RFR: 8315097: Rename createJavaProcessBuilder [v5]
Leo Korinth
lkorinth at openjdk.org
Fri Oct 20 08:34:35 UTC 2023
On Thu, 19 Oct 2023 15:16:13 GMT, Leo Korinth <lkorinth at openjdk.org> wrote:
>> Rename createJavaProcessBuilder so that it is not used by mistake instead of createTestJvm.
>>
>> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed -i -e "s/createJavaProcessBuilder(/createJavaProcessBuilderIgnoreTestJavaOpts(/g"`
>>
>> Then I have manually modified ProcessTools.java. In that file I have moved one version of createJavaProcessBuilder so that it is close to the other version. Then I have added a javadoc comment in bold telling:
>>
>> /**
>> * Create ProcessBuilder using the java launcher from the jdk to
>> * be tested.
>> *
>> * <p><b> Please observe that you likely should use
>> * createTestJvm() instead of this method because createTestJvm()
>> * will add JVM options from "test.vm.opts" and "test.java.opts"
>> * </b> and this method will not do that.
>> *
>> * @param command Arguments to pass to the java command.
>> * @return The ProcessBuilder instance representing the java command.
>> */
>>
>>
>> I have used the name createJavaProcessBuilderIgnoreTestJavaOpts because of the name of Utils.prependTestJavaOpts that adds those VM flags. If you have a better name I could do a rename of the method. I kind of like that it is long and clumsy, that makes it harder to use...
>>
>> I have run tier 1 testing, and I have started more exhaustive testing.
>
> Leo Korinth has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains ten commits:
>
> - Batch update using sed
>
> find -name "*.java" | xargs -n 1 sed -i -e "s/createJavaProcessBuilder(/createLimitedJavaTestProcessBuilder(/g"
> find -name "*.java" | xargs -n 1 sed -i -e "s/createTestJvm(/createJavaTestProcessBuilder(/g"
> find -name "*.java" | xargs -n 1 sed -i -e "s/import static jdk.test.lib.process.ProcessTools.createJavaProcessBuilder/import static jdk.test.lib.process.ProcessTools.createLimitedJavaTestProcessBuilder/g"
> - Merge branch '_master_jdk' into _8315097
> - explain usage
> - Revert "8315097: Rename createJavaProcessBuilder"
>
> This reverts commit 4b2d171133c40c5c48114602bfd0d4da75531317.
> - Revert "copyright"
>
> This reverts commit f3418c80cc0d4cbb722ee5e368f1a001e898b43e.
> - Revert "fix static import"
>
> This reverts commit 27da71508aec9a4bec1c0ad07031887286580171.
> - fix static import
> - copyright
> - 8315097: Rename createJavaProcessBuilder
Just ignore what I just pushed, I will have a new version out
sorry...
-------------
PR Comment: https://git.openjdk.org/jdk/pull/15452#issuecomment-1772309579
PR Comment: https://git.openjdk.org/jdk/pull/15452#issuecomment-1772309992
More information about the serviceability-dev
mailing list