RFR: 8315097: Rename createJavaProcessBuilder [v6]
Leo Korinth
lkorinth at openjdk.org
Tue Oct 24 07:49:30 UTC 2023
> Rename createJavaProcessBuilder so that it is not used by mistake instead of createTestJvm.
>
> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed -i -e "s/createJavaProcessBuilder(/createJavaProcessBuilderIgnoreTestJavaOpts(/g"`
>
> Then I have manually modified ProcessTools.java. In that file I have moved one version of createJavaProcessBuilder so that it is close to the other version. Then I have added a javadoc comment in bold telling:
>
> /**
> * Create ProcessBuilder using the java launcher from the jdk to
> * be tested.
> *
> * <p><b> Please observe that you likely should use
> * createTestJvm() instead of this method because createTestJvm()
> * will add JVM options from "test.vm.opts" and "test.java.opts"
> * </b> and this method will not do that.
> *
> * @param command Arguments to pass to the java command.
> * @return The ProcessBuilder instance representing the java command.
> */
>
>
> I have used the name createJavaProcessBuilderIgnoreTestJavaOpts because of the name of Utils.prependTestJavaOpts that adds those VM flags. If you have a better name I could do a rename of the method. I kind of like that it is long and clumsy, that makes it harder to use...
>
> I have run tier 1 testing, and I have started more exhaustive testing.
Leo Korinth has updated the pull request incrementally with six additional commits since the last revision:
- static import
- copyright
- whitespace
- whitespace
- sed
- fix test/lib/jdk/test/lib/process/ProcessTools.java
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/15452/files
- new: https://git.openjdk.org/jdk/pull/15452/files/f80dda8d..2f57a32d
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=15452&range=05
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=15452&range=04-05
Stats: 1580 lines in 560 files changed: 44 ins; 34 del; 1502 mod
Patch: https://git.openjdk.org/jdk/pull/15452.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/15452/head:pull/15452
PR: https://git.openjdk.org/jdk/pull/15452
More information about the serviceability-dev
mailing list