RFR: 8315884: New Object to ObjectMonitor mapping [v6]

Coleen Phillimore coleenp at openjdk.org
Tue Jul 23 19:09:43 UTC 2024


On Tue, 23 Jul 2024 12:34:45 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:

>> I was thinking it was referring to `ObjectSynchronizer::waitUninterruptibly` added the same commit as the comment b3bf31a0a08da679ec2fd21613243fb17b1135a9
>
> git backout restored the old wrong comment.  We should fix this separately.

Suggestion:

    // If we were to use wait() instead of waitInterruptibly() then

>> I think I was thinking of the names as a prefix to refer to the `Count of the table` and `Size of the table`. And not the `Number of tables`. But I can see the confusion. 
>> 
>> `ConcurrentHashTable` tracks no statistics except for JFR which added some counters directly into the implementation. All statistics are for the users to manage, even if there are helpers for gather these statistics. 
>> 
>> The current implementation is based on what we do for the StringTable and SymbolTable
>
> In the other tables, it's called _items_count and it determines the load_factor for triggering concurrent work.  We should rename this field items_count to match, and also since it's consistent.

Suggestion:

  volatile size_t _items_count;

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/20067#discussion_r1687990861
PR Review Comment: https://git.openjdk.org/jdk/pull/20067#discussion_r1688564267


More information about the serviceability-dev mailing list