RFR: 8336254: Virtual thread implementation + test updates [v2]

Serguei Spitsyn sspitsyn at openjdk.org
Wed Jul 24 10:45:35 UTC 2024


On Fri, 19 Jul 2024 16:59:54 GMT, Alan Bateman <alanb at openjdk.org> wrote:

>> Bringover some of the changes accumulated in the loom repo to the main line, most of these changes are test updates and have been baking in the loom repo for several months. The motive is partly to reduce the large set of changes that have accumulated in the loom repo, and partly to improve robustness and test coverage in the main line. The changes don't include any of the larger changes in the loom repo that are part of future JEPs.
>> 
>> Implementation:
>> - Robustness improvements to not throw OOME when unparking a virtual thread.
>> - Robustness improvements to reduce class loading when a virtual thread parks or parks when pinned (jdk.internal.misc.VirtualThreads is removed, jdk.internal.event.VirtualThreadPinnedEvent is eagerly loaded)
>> - VirtualThread changes to reduce contention on timer queues when doing timed-park
>> 
>> Tests:
>> - New tests for monitor enter/exit/wait/notify (this is a subset of the tests in the loom repo, we can't move many tests because they depend on on the changes to the object monitor implementation)
>> - New test infrastructure to allow tests use a custom scheduler. This updates many tests to make use of this infrastructure, the "local" ThreadBuidlers is removed.
>> - More test scenarios added to ThreadAPI and JVMTI GetThreadStateTest.java 
>> - New test for ThreadMXBean.getLockedMonitor with synchronized native methods
>> - Reimplement of JVMTI VThreadEvent test to improve reliability
>> - Rename some tests to get consistent naming
>> - Diagnostic output in several stress tests to help trace progress in the event of a timeout
>> 
>> Testing: tier1-6
>
> Alan Bateman has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains eight additional commits since the last revision:
> 
>  - Merge
>  - Fix typo in comment, missing copyright update, test nits
>  - Merge
>  - Drop JLA updates for this update
>  - Merge
>  - Merge
>  - Update copyright headers
>  - Initial commit

Looks good. Thank you for porting this to Main line.

test/jdk/java/lang/Thread/virtual/ParkWithFixedThreadPool.java line 63:

> 61:             };
> 62: 
> 63:             ThreadFactory factory = VThreadScheduler.virtualThreadFactory(scheduler);

Nit: So, there is no name for this thread anymore. Just wanted to note thread names are useful in debugging.

-------------

Marked as reviewed by sspitsyn (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/20143#pullrequestreview-2187747262
PR Review Comment: https://git.openjdk.org/jdk/pull/20143#discussion_r1684084924


More information about the serviceability-dev mailing list