RFR: 8337511: Implement JEP 404: Generational Shenandoah (Experimental) [v5]
William Kemper
wkemper at openjdk.org
Tue Oct 29 18:20:33 UTC 2024
On Sat, 26 Oct 2024 01:33:23 GMT, Zhengyu Gu <zgu at openjdk.org> wrote:
>> William Kemper has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 492 commits:
>>
>> - Merge remote-tracking branch 'shenandoah/master' into great-genshen-pr-redux
>> - Merge
>> - 8342560: GenShen: Fix confusing method name
>>
>> Reviewed-by: ysr
>> - 8342564: GenShen: Only reference young/old generation names in generational mode
>>
>> Reviewed-by: xpeng, ysr
>> - Merge remote-tracking branch 'jdk/master' into great-genshen-pr-redux
>> - Merge remote-tracking branch 'shenandoah/master' into great-genshen-pr-redux
>> - 8342214: GenShen: Reduce code duplication in shFreeSet with iterator abstraction
>>
>> Reviewed-by: kdnilsen, ysr
>> - 8342239: GenShen: Revert changes in adaptive heuristic to avoid overflow on 32 bit
>>
>> Reviewed-by: ysr
>> - 8342278: GenShen: Move non-generational mode test out of generational test configuration
>>
>> Reviewed-by: ysr
>> - 8342255: GenShen: Remove unnecessary enum initial values
>>
>> Reviewed-by: ysr
>> - ... and 482 more: https://git.openjdk.org/jdk/compare/71583222...2a2aa408
>
> src/hotspot/share/gc/shenandoah/shenandoahAgeCensus.cpp line 243:
>
>> 241: void ShenandoahAgeCensus::update_tenuring_threshold() {
>> 242: if (!ShenandoahGenerationalAdaptiveTenuring) {
>> 243: _tenuring_threshold[_epoch] = InitialTenuringThreshold;
>
> `InitialTenuringThreshold` is currently only used by parallel GC, so that the flag's constraint is only implemented in parallel GC [here](https://github.com/openjdk/jdk/blob/master/src/hotspot/share/gc/shared/jvmFlagConstraintsGC.cpp#L177) . Now, Shenandoah reuses the flag, you may want to consider to parallel GC's implementation into `shared`.
Good catch. https://bugs.openjdk.org/browse/JDK-8343226
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21273#discussion_r1821337048
More information about the serviceability-dev
mailing list