RFR: 8305895: Implement JEP 450: Compact Object Headers (Experimental) [v11]

Thomas Stuefe stuefe at openjdk.org
Tue Sep 17 10:16:24 UTC 2024


On Wed, 11 Sep 2024 13:50:59 GMT, Johan Sjölen <jsjolen at openjdk.org> wrote:

>> Roman Kennke has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Fix FullGCForwarding initialization
>
> src/hotspot/share/memory/metaspace.cpp line 656:
> 
>> 654:     // Adjust size of the compressed class space.
>> 655: 
>> 656:     const size_t res_align = reserve_alignment();
> 
> Can you change the name to `root_chunk_size`?

It feels wrong, since this is a deeply hidden implementation detail.\

I will remove this temporary variable, which will also make the diff smaller.

> src/hotspot/share/memory/metaspace.hpp line 112:
> 
>> 110:   static size_t max_allocation_word_size();
>> 111: 
>> 112:   // Minimum allocation alignment, in bytes. All MetaData shall be aligned correclty
> 
> Nit: Spelling, "correctly"

Fixed

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/20677#discussion_r1762968742
PR Review Comment: https://git.openjdk.org/jdk/pull/20677#discussion_r1762972938


More information about the serviceability-dev mailing list