RFR: 8346567: Make Class.getModifiers() non-native
Alan Bateman
alanb at openjdk.org
Tue Feb 4 14:00:13 UTC 2025
On Mon, 9 Dec 2024 19:26:53 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:
> The Class.getModifiers() method is implemented as a native method in java.lang.Class to access a field that we've calculated when creating the mirror. The field is final after that point. The VM doesn't need it anymore, so there's no real need for the jdk code to call into the VM to get it. This moves the field to Java and removes the intrinsic code. I promoted the compute_modifiers() functions to return int since that's how java.lang.Class uses the value. It should really be an unsigned short though.
>
> There's a couple of JMH benchmarks added with this change. One does show that for array classes for non-bootstrap class loader, this results in one extra load which in a long loop of just that, is observable. I don't think this is real life code. The other benchmarks added show no regression.
>
> Tested with tier1-8.
Good cleanup.
src/java.base/share/classes/java/lang/Class.java line 244:
> 242: classLoader = loader;
> 243: componentType = arrayComponentType;
> 244: modifiers = dummyModifiers;
I realize this ctor isn't used but "dummyModifiers" looks very strange as parameter name when compared to the others, renaming it to something like "mods" would make it less confusing for anyone reading through this code.
-------------
Marked as reviewed by alanb (Reviewer).
PR Review: https://git.openjdk.org/jdk/pull/22652#pullrequestreview-2592938860
PR Review Comment: https://git.openjdk.org/jdk/pull/22652#discussion_r1941220263
More information about the serviceability-dev
mailing list