RFR: Store verification
Andrew Haley
aph at redhat.com
Thu Oct 20 15:46:48 UTC 2016
On 20/10/16 14:48, Roman Kennke wrote:
> http://cr.openjdk.java.net/~rkennke/storechecks/webrev/
>
> Ok to push?
I really don't like all those boolean constants "true" and "false" all
over the place. Yeah, I know I've done it elsewhere in aarch64.ad and
it's bad style. Mea culpa, but I don't want it to spread any further.
Please either define loadInsn() and storeInsn() or define an enum
enum (isLoad, isStore)
and use it instead of a bool.
+ orr(rval, zr, value);
+ // mov(rval, value);
+ mov(raddr, addr);
What is this change for? Why orr instead of mov?
+ // Macro instructions for accessing and updating the condition flags
+ inline void get_cflags(Register reg)
+ {
+ mrs(0b011, 0b0100, 0b0010, 0b000, reg);
+ }
+
+ inline void set_cflags(Register reg)
+ {
+ msr(0b011, 0b0100, 0b0010, 0b000, reg);
+ }
+
get_nzcv() would be easier for the reader to understand, and matches
ARM's assembly language.
Andrew.
More information about the shenandoah-dev
mailing list