[15] RFR 8244243: Shenandoah: Cleanup Shenandoah phase timing tracking and JFR event supporting
Aleksey Shipilev
shade at redhat.com
Wed May 6 11:30:39 UTC 2020
On 5/1/20 7:08 PM, Zhengyu Gu wrote:
> Bug: https://bugs.openjdk.java.net/browse/JDK-8244243
> Webrev: http://cr.openjdk.java.net/~zgu/JDK-8244243/webrev.00/index.html
It is a useful cleanup. I think it is better to get that cleanup complete:
*) It feels it should be moved to shenandoahPhaseTimings and be renamed to ShenandoahTimingsTracker,
to match ShenandoahWorkerTimingsTracker. "Trackers" are the good name for something that only
touches the timings.
*) Current ShenandoahGCPhaseTiming also carries current_phase for
Shenandoah{Parallel,Concurrent}WorkerSession, shouldn't that be moved to ShenandoahGCPhase?
*) Do these really need to be subclasses? I think delegation is called for here.
class ShenandoahGCPhase : public ShenandoahGCPhaseTiming
class ShenandoahPausePhase : public ShenandoahGCPhaseTiming
class ShenandoahConcurrentPhase : public ShenandoahGCPhaseTiming
--
Thanks,
-Aleksey
More information about the shenandoah-dev
mailing list