RFR: 8261125: Move VM_Operation to vmOperation.hpp
Daniel D.Daugherty
dcubed at openjdk.java.net
Thu Feb 4 19:47:45 UTC 2021
On Thu, 4 Feb 2021 17:15:37 GMT, Thomas Stuefe <stuefe at openjdk.org> wrote:
>> vmOperations.hpp declares the VM_Operation class, as well as a hodge podge of subclasses such as VM_ForceSafepoint, VM_DeoptimizeFrame.
>>
>> Out of the 1000 hotspot .o files, about 680 include vmOperations.hpp (mostly transitively). In most cases, they just need to use the VM_Operation class.
>>
>> So we should move VM_Operation to its own header: vmOperation.hpp (no "s").
>>
>> After the refactoring, vmOperations.hpp is included only 64 times. The inclusion count of threadSMR.hpp is also reduced from 687 to 99. HotSpot build time is improved by about 0.4%.
>>
>> Tested with mach5: tier1, builds-tier2, builds-tier3, builds-tier4 and builds-tier5. Also locally: aarch64, arm, ppc64, s390, x86, and zero.
>
> Hi Ioi,
>
> I like all these include cleanups! How do you find these, do you analyze the include tree?
>
> I think vmOperation vs vmOperations could be confusing. But have no immediate better idea. If others are fine with it, I am too.
>
> Can you please enable GA so we see that our weirder platforms build?
>
> Otherwise, looks good.
>
> ..Thomas
A drive-by comment...
The class is named VM_Operation, but the file is named vmOperation.hpp.
The missing '_' in the file name is a bit of a disconnect, but there are worse
in the code base...
-------------
PR: https://git.openjdk.java.net/jdk/pull/2398
More information about the shenandoah-dev
mailing list