RFR: 8261125: Move VM_Operation to vmOperation.hpp
David Holmes
dholmes at openjdk.java.net
Thu Feb 4 22:27:40 UTC 2021
On Thu, 4 Feb 2021 05:38:49 GMT, Ioi Lam <iklam at openjdk.org> wrote:
> vmOperations.hpp declares the VM_Operation class, as well as a hodge podge of subclasses such as VM_ForceSafepoint, VM_DeoptimizeFrame.
>
> Out of the 1000 hotspot .o files, about 680 include vmOperations.hpp (mostly transitively). In most cases, they just need to use the VM_Operation class.
>
> So we should move VM_Operation to its own header: vmOperation.hpp (no "s").
>
> After the refactoring, vmOperations.hpp is included only 64 times. The inclusion count of threadSMR.hpp is also reduced from 687 to 99. HotSpot build time is improved by about 0.4%.
>
> Tested with mach5: tier1, builds-tier2, builds-tier3, builds-tier4 and builds-tier5. Also locally: aarch64, arm, ppc64, s390, x86, and zero.
Hi Ioi,
The distinction between vmOperation versus vmOperations is far too subtle. Perhaps as Dan implied vm_Operation.hpp or VM_Operation.hpp (though that breaks normal - odd - naming convention).
I assume most files that include vmOperation.hpp are those that define VM_Operation subclasses?
Thanks,
David
src/hotspot/share/runtime/vmOperation.hpp line 2:
> 1: /*
> 2: * Copyright (c) 1997, 2021, Oracle and/or its affiliates. All rights reserved.
New file so single copyright year.
-------------
Changes requested by dholmes (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/2398
More information about the shenandoah-dev
mailing list