RFR: 8259849: Shenandoah: Rename store-val to IU-barrier
Zhengyu Gu
zgu at openjdk.java.net
Fri Jan 15 18:54:07 UTC 2021
On Fri, 15 Jan 2021 18:19:09 GMT, Roman Kennke <rkennke at openjdk.org> wrote:
> We named the IU barriers StoreValEnqueueBarrier and various similar variations of this. Instead of naming it after how it's implemented, we should name it after its purpose: support IU-marking. It also looks confusing to have enqueue_barrier() and similar stuff, where no barrier is actually enqueued.
>
> The renaming was 100% mechanical.
>
> Testing:
> - [ ] hotspot_gc_shenandoah (x86_64, x86_32, aarch64)
Some file's copyright year need to be updated. Otherwise, looks good.
-------------
Marked as reviewed by zgu (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/2104
More information about the shenandoah-dev
mailing list