RFR: 8275035: Clean up worker thread infrastructure [v2]

Per Liden pliden at openjdk.java.net
Thu Oct 14 09:03:18 UTC 2021


> I propose that we clean up our GangWorker/WorkGang and related classes, to remove abstractions we no longer need (after CMS was removed, MutexDispatcher was removed, Parallel is now using WorkGang, etc) and adjusting names as follows:
> 
> * Rename AbstractGangTask to WorkerTask
> * Rename WorkGang to WorkerThreads
> * Fold GangWorker into WorkerThread
> * Fold WorkManager into WorkerThreads
> * Move SubTaskDone and friends to a new workerUtils.hpp/cpp
> 
> I've split things up into several commits to make it easier to review.
> 
> Testing: Passes Tier 1-3 on all Oracle platforms.

Per Liden has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 21 commits:

 - Merge master
 - Clean up naming in ReferenceProcessor
 - Clean up naming in Shenandoah
 - Clean up naming in HeapDumper/HeapInspector
 - Clean up naming in G1
 - Clean up naming in pretouch
 - Clean up naming in WeakProcessor
 - Clean up naming in ZGC
 - Remove unused log tag
 - Rename workgroup.hpp/cpp to workerThread.hpp/cpp
 - ... and 11 more: https://git.openjdk.java.net/jdk/compare/8b1b6f9f...9a89f785

-------------

Changes: https://git.openjdk.java.net/jdk/pull/5886/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5886&range=01
  Stats: 2415 lines in 105 files changed: 881 ins; 1083 del; 451 mod
  Patch: https://git.openjdk.java.net/jdk/pull/5886.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/5886/head:pull/5886

PR: https://git.openjdk.java.net/jdk/pull/5886


More information about the shenandoah-dev mailing list