RFR: 8292153: x86: Represent Registers as values
Andrew Haley
aph at openjdk.org
Wed Aug 10 10:07:37 UTC 2022
On Tue, 9 Aug 2022 23:25:27 GMT, Vladimir Ivanov <vlivanov at openjdk.org> wrote:
> As of now, Registers of all sorts use pointer-based representation. It's error-prone, because compilers perform implicit conversions between pointers and integral values. Also, it constraints `MacroAssembler` API where it may introduce ambiguity between overloads.
>
> Proposed change hides pointer representation behind value class.
>
> Pointer-based representation is kept to avoid massive migration of users (from `->` to `.`) and to enable incremental migration on per-platform basis (pointer-based representation is assumed in shared code).
>
> Code quality doesn't suffer (and even slightly improves):
> https://godbolt.org/z/d8dGM1eY1
>
> (I noticed one downside: slowdebug builds become slower, because `operator->` isn't inlined there. If it becomes a problem, migrating performance-sensitive places from `->` to `.` should solve the problem.)
>
> Testing: hs-tier1 - hs-tier5
>
> PS: a number of cleanups are incorporated. In particular, I decided to expand all macros from `register.hpp` because IMO they add confusion rather than improve readability.
src/hotspot/cpu/x86/stubGenerator_x86_32.cpp line 3509:
> 3507: const Register g = rsi;
> 3508: const Register h = rdi;
> 3509: const Register empty = noreg; // will never be used, in order not
Shade and I were looking at this bug a week or so ago, but agreed to leave it because this patch would find and fix it. Good!
-------------
PR: https://git.openjdk.org/jdk/pull/9815
More information about the shenandoah-dev
mailing list