RFR: 8293524: RISC-V: Use macro-assembler functions as appropriate
Fei Yang
fyang at openjdk.org
Thu Sep 8 03:30:12 UTC 2022
Use of assember functions on riscv can be improved. For example, we use 'fence(0xf, 0xf)' in function TemplateInterpreterGenerator::generate_safept_entry_for to emit a full memory fence instruction. Here we should use 'membar(MacroAssembler::AnyAny)' instead, which would make the code more readable. This also replace some calls to 'li' with 'mv' so that it will be more consistent when moving integer constant.
Testing: Tier1 tested on Linux-riscv64 SiFive Unmatched board.
-------------
Commit messages:
- 8293524: RISC-V: Use macro-assembler functions as appropriate
Changes: https://git.openjdk.org/jdk/pull/10210/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=10210&range=00
Issue: https://bugs.openjdk.org/browse/JDK-8293524
Stats: 78 lines in 13 files changed: 0 ins; 0 del; 78 mod
Patch: https://git.openjdk.org/jdk/pull/10210.diff
Fetch: git fetch https://git.openjdk.org/jdk pull/10210/head:pull/10210
PR: https://git.openjdk.org/jdk/pull/10210
More information about the shenandoah-dev
mailing list