RFR: 8293524: RISC-V: Use macro-assembler functions as appropriate
Fei Yang
fyang at openjdk.org
Fri Sep 9 00:19:48 UTC 2022
On Thu, 8 Sep 2022 06:16:29 GMT, Aleksey Shipilev <shade at openjdk.org> wrote:
>> Use of assember functions on riscv can be improved. For example, we use 'fence(0xf, 0xf)' in function TemplateInterpreterGenerator::generate_safept_entry_for to emit a full memory fence instruction. Here we should use 'membar(MacroAssembler::AnyAny)' instead, which would make the code more readable. This also replace some calls to 'li' with 'mv' so that it will be more consistent when moving integer constant.
>>
>> Testing: Tier1 tested on Linux-riscv64 SiFive Unmatched board.
>
> Marked as reviewed by shade (Reviewer).
@shipilev @feilongjiang : Thanks for reviewing this.
-------------
PR: https://git.openjdk.org/jdk/pull/10210
More information about the shenandoah-dev
mailing list