RFR: Add generations to freeset [v8]

Kelvin Nilsen kdnilsen at openjdk.org
Fri Apr 21 18:41:50 UTC 2023


On Thu, 20 Apr 2023 19:48:30 GMT, Kelvin Nilsen <kdnilsen at openjdk.org> wrote:

>> src/hotspot/share/gc/shenandoah/shenandoahFreeSet.cpp line 610:
>> 
>>> 608: 
>>> 609: // If idx represents a collector bound, recompute the collector bounds, returning true iff bounds were adjusted.
>>> 610: bool ShenandoahFreeSet::adjust_collector_bounds_if_touched(size_t idx) {
>> 
>> This really feels like there should be a `RegionFreeSet` class with instances for `mutator`, `collector`, and `old_collector`. There's a lot of code duplication here. A refactoring for another PR.
>
> Agree that refactoring would be nice in the future.

I've gone partway there, but more thorough refactoring can happen in a future PR.

-------------

PR Review Comment: https://git.openjdk.org/shenandoah/pull/250#discussion_r1174059301


More information about the shenandoah-dev mailing list