RFR: 8299703: GenShen: improvements in card scanning [v6]
Y. Srinivas Ramakrishna
ysr at openjdk.org
Thu Feb 2 02:10:29 UTC 2023
On Thu, 2 Feb 2023 00:06:21 GMT, William Kemper <wkemper at openjdk.org> wrote:
>> Y. Srinivas Ramakrishna has updated the pull request incrementally with one additional commit since the last revision:
>>
>> guarantees to asserts (non-production), and warnings (production);
>> review feedback.
>
> src/hotspot/share/gc/shenandoah/shenandoahScanRemembered.inline.hpp line 687:
>
>> 685: // compiler & interpreter are imprecise.
>> 686: if (p < left && !obj->is_objArray()) {
>> 687: if (OBJ_MARK_IMPRECISE) {
>
> The code would be simpler if the case for handling `OBJ_MARK_IMPRECISE` were left out - perhaps moved to a descriptive comment? If we leave it in, could we name it `OBJ_MARK_ALWAYS_IMPRECISE` . The barriers do use imprecise card marks, so it's confusing to see this defined as `false`.
Yes, I agree that the naming is confusing, plus the unnecessary code clutter.
I removed that arm and associated preprocessor def'n, and fixed up the comments.
-------------
PR: https://git.openjdk.org/shenandoah/pull/193
More information about the shenandoah-dev
mailing list