RFR: 8305896: Alternative full GC forwarding [v16]
Aleksey Shipilev
shade at openjdk.org
Tue May 2 17:37:28 UTC 2023
On Tue, 2 May 2023 17:12:12 GMT, Roman Kennke <rkennke at openjdk.org> wrote:
>> src/hotspot/share/gc/shared/slidingForwarding.hpp line 121:
>>
>>> 119: size_t _region_size_words;
>>> 120: size_t _region_size_words_shift;
>>> 121: HeapWord** _bases_table;
>>
>> Small nit. For clarity, I would prefer if we had a real structure here, e.g.:
>>
>> struct region_forwarding { HeapWord* dest; HeapWord* alt_dest; };
>> region_forwarding* _table;
>
> Ok, I am changing it. It looks like it's introducing a branch on the decoding-path though. I am not sure if a C++ compiler would optimise it to a branch-free code, though. It's probably a very minor concern.
No wait, let's keep it as `HeapWord*` array. The fact that alternate selection is just a math addition matters a bit for decoding performance. I think it does not complicate the code all that much to warrant extra abstraction here.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/13582#discussion_r1182832355
More information about the shenandoah-dev
mailing list