RFR: 8307806: Rename Atomic::fetch_and_add and friends
Kim Barrett
kbarrett at openjdk.org
Wed May 10 13:09:31 UTC 2023
Please review this renaming of Atomic::fetch_and_add and friends to be
consistent with the naming convention recently chosen for atomic bitops. That
is, make the following name changes for class Atomic and it's implementation:
- fetch_and_add => fetch_then_add
- add_and_fetch => add_then_fetch
Testing:
mach5 tier1-3
GHA testing
-------------
Commit messages:
- rename in tests
- rename uses
- rename impl
Changes: https://git.openjdk.org/jdk/pull/13896/files
Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=13896&range=00
Issue: https://bugs.openjdk.org/browse/JDK-8307806
Stats: 156 lines in 39 files changed: 0 ins; 0 del; 156 mod
Patch: https://git.openjdk.org/jdk/pull/13896.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/13896/head:pull/13896
PR: https://git.openjdk.org/jdk/pull/13896
More information about the shenandoah-dev
mailing list