RFR: 8324649: Shenandoah: refactor implementation of free set [v39]
Roman Kennke
rkennke at openjdk.org
Tue Apr 9 19:36:16 UTC 2024
On Thu, 28 Mar 2024 16:06:58 GMT, Kelvin Nilsen <kdnilsen at openjdk.org> wrote:
>> Several objectives:
>> 1. Reduce humongous allocation failures by segregating regular regions from humongous regions
>> 2. Do not retire regions just because an allocation failed within the region if the memory remaining within the region is large enough to represent a LAB
>> 3. Track range of empty regions in addition to range of available regions in order to expedite humongous allocations
>> 4. Treat collector reserves as available for Mutator allocations after evacuation completes
>> 5. Improve encapsulation so as to enable an OldCollector reserve for future integration of generational Shenandoah
>>
>> We have compared performance of existing FreeSet implementation with the proposed PR over a broad set of performance workloads and see that the impact is mostly neutral.
>>
>> Comparing 105235.0 metrics from control, 220638.0 from experiment.
>> Compare: 0.589s
>> Most impacted benchmarks | Most impacted metrics
>> -------------------------------------------------------------------------------------------------------
>> Shenandoah/jython | cwr_total
>>
>>
>> Only in experiment | Only in control
>> -------------------------------------------------------------------------------------------------------
>> crypto.signverify/trigger_failure | crypto.rsa/cmr_thread_roots
>> extremem-large-31g/adjust_pointers | scimark.sparse.small/concurrent_thread_roots
>> extremem-large-31g/calculate_addresses | xml.transform/concurrent_thread_roots
>> crypto.signverify/class_unloading_rendezvous | mpegaudio/concurrent_weak_roots
>> serial/cmr_total | crypto.rsa/ctr_thread_roots
>>
>> Shenandoah
>> -------------------------------------------------------------------------------------------------------
>> +5.64% jython/cwr_total p=0.00037
>> Control: 1.928ms (+/-272.40us) 170
>> Test: 2.037ms (+/-322.73us) 344
>
> Kelvin Nilsen has updated the pull request incrementally with one additional commit since the last revision:
>
> Remove debugging instrumentation
src/hotspot/share/gc/shenandoah/shenandoahFreeSet.hpp line 45:
> 43: // break abstraction rules, because efficient implementation requires assumptions about superclass internals that
> 44: // might be violatee through future software maintenance.
> 45: class ShenandoahSimpleBitMap {
I think this class should go into its own set of files. It would certainly help readability of ShFreeSet which is now somewhat dominated by ShSimpleBitMap.
src/hotspot/share/gc/shenandoah/shenandoahFullGC.cpp line 915:
> 913: public:
> 914: ShenandoahPostCompactClosure() : _heap(ShenandoahHeap::heap()), _live(0) {
> 915: _heap->free_set()->clear();
Why is that ok?
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17561#discussion_r1558187740
PR Review Comment: https://git.openjdk.org/jdk/pull/17561#discussion_r1558185718
More information about the shenandoah-dev
mailing list