RFR: 8337563: NMT: rename MEMFLAGS to MemFlag
Kim Barrett
kbarrett at openjdk.org
Thu Aug 15 08:01:50 UTC 2024
On Thu, 15 Aug 2024 07:46:34 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:
> > > Whatever we choose we also need to consider the mt prefix of things like mtGC, mtClass, etc.
> >
> >
> > And what does that stand for: memory type? memory tracker? Arguably they should have been nmtGC etc.
>
> The memflags.hpp file says that it's a memory type:
>
> ```
> +#define MEMORY_TYPES_DO(f) \
> + /* Memory type by sub systems. It occupies lower byte. */ \
> + f(mtJavaHeap, "Java Heap") /* Java heap */ \
> ```
>
> My guess is that at some point there was an incomplete rename from "memory type".
Note that we used to have `typedef MemType MEMFLAGS;`
-------------
PR Comment: https://git.openjdk.org/jdk/pull/20497#issuecomment-2290846873
More information about the shenandoah-dev
mailing list