RFR: 8324649: Shenandoah: refactor implementation of free set [v4]
Kelvin Nilsen
kdnilsen at openjdk.org
Wed Jan 31 16:28:16 UTC 2024
On Mon, 29 Jan 2024 22:57:07 GMT, Y. Srinivas Ramakrishna <ysr at openjdk.org> wrote:
>> Kelvin Nilsen has updated the pull request incrementally with two additional commits since the last revision:
>>
>> - Fix typo in comment
>> - Remove unnecessary include
>
> src/hotspot/share/gc/shenandoah/shenandoahFreeSet.hpp line 55:
>
>> 53: size_t _capacity_of[NumFreeSets];
>> 54: size_t _used_by[NumFreeSets];
>> 55: size_t _region_counts[NumFreeSets];
>
> Similarly, document what these values hold at any time; just a line is enough, e.g.
>
>
> // For any given type, its _capacity_of is its net capacity, and _used_by the amount used.
> // _region_counts is the number of regions of that type.
>
>
> Why the extra `_of` and `_by`? Wouldn't it be more consistent with naming elsewhere
> to just say `capacity` and `used`?
Made this change as well. Thanks.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17561#discussion_r1473112070
More information about the shenandoah-dev
mailing list