RFR: 8328944: NMT reports "unknown" memory

Johan Sjölen jsjolen at openjdk.org
Mon Nov 4 13:15:29 UTC 2024


On Mon, 4 Nov 2024 08:34:00 GMT, Thomas Stuefe <stuefe at openjdk.org> wrote:

> > Eventually the goal would be not to use mtNone anywhere, but we are not there quite yet.
> 
> I think this is neither realistic nor desirable. mtNone means "don't know yet; will do later". This is perfectly valid for cases where
> 
>     * you allocate something on behalf of someone else; obviously, you don't know what he intends to do with it
> 
>     * when you reserve a range that is later shared by multiple tags.
> 
> 
> If we move to more fine granular tags, or something like hierarchical tags, the latter point will become more important. Therefore, mtNone has its place.

It seems to me like the first case isn't a case at all, as that someone else can always give you a tag for the memory. With more granular or hierarchical tags, the case for `mtNone` seems even rarer. We can then always have a top-level tag for the category: `mtCardTable <: mtGC`.

Now I'm just thinking out loud: `mtNone` could be renamed to `mtAny` in the case that we do have hierarchical tags, as to represent `top` in a partially ordered set.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/21843#issuecomment-2454684099


More information about the shenandoah-dev mailing list