RFR: 8342560: GenShen: Fix confusing method name [v3]
William Kemper
wkemper at openjdk.org
Fri Oct 18 16:55:44 UTC 2024
> Rename `is_old` to make it more clear that this about pointers that are outside the scope of a young collection.
William Kemper has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains 10 additional commits since the last revision:
- Merge remote-tracking branch 'shenandoah/master' into fix-confusing-method
- Use an even better name, add an explanatory comment
- 8342564: GenShen: Only reference young/old generation names in generational mode
Reviewed-by: xpeng, ysr
- 8342214: GenShen: Reduce code duplication in shFreeSet with iterator abstraction
Reviewed-by: kdnilsen, ysr
- 8342239: GenShen: Revert changes in adaptive heuristic to avoid overflow on 32 bit
Reviewed-by: ysr
- 8342278: GenShen: Move non-generational mode test out of generational test configuration
Reviewed-by: ysr
- 8342255: GenShen: Remove unnecessary enum initial values
Reviewed-by: ysr
- Fix confusing method name
- Revert "Test if we still (or ever) needed confusing is_old method"
This reverts commit 5fcaef551d3286bd3e5eae485ac11c5b15ce7ed8.
- Test if we still (or ever) needed confusing is_old method
-------------
Changes:
- all: https://git.openjdk.org/shenandoah/pull/517/files
- new: https://git.openjdk.org/shenandoah/pull/517/files/9bb4dfb7..90c81bdb
Webrevs:
- full: https://webrevs.openjdk.org/?repo=shenandoah&pr=517&range=02
- incr: https://webrevs.openjdk.org/?repo=shenandoah&pr=517&range=01-02
Stats: 0 lines in 0 files changed: 0 ins; 0 del; 0 mod
Patch: https://git.openjdk.org/shenandoah/pull/517.diff
Fetch: git fetch https://git.openjdk.org/shenandoah.git pull/517/head:pull/517
PR: https://git.openjdk.org/shenandoah/pull/517
More information about the shenandoah-dev
mailing list