RFR: 8342560: GenShen: Fix confusing method name [v3]

William Kemper wkemper at openjdk.org
Fri Oct 18 16:55:45 UTC 2024


On Thu, 17 Oct 2024 21:43:53 GMT, Y. Srinivas Ramakrishna <ysr at openjdk.org> wrote:

>> William Kemper has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains 10 additional commits since the last revision:
>> 
>>  - Merge remote-tracking branch 'shenandoah/master' into fix-confusing-method
>>  - Use an even better name, add an explanatory comment
>>  - 8342564: GenShen: Only reference young/old generation names in generational mode
>>    
>>    Reviewed-by: xpeng, ysr
>>  - 8342214: GenShen: Reduce code duplication in shFreeSet with iterator abstraction
>>    
>>    Reviewed-by: kdnilsen, ysr
>>  - 8342239: GenShen: Revert changes in adaptive heuristic to avoid overflow on 32 bit
>>    
>>    Reviewed-by: ysr
>>  - 8342278: GenShen: Move non-generational mode test out of generational test configuration
>>    
>>    Reviewed-by: ysr
>>  - 8342255: GenShen: Remove unnecessary enum initial values
>>    
>>    Reviewed-by: ysr
>>  - Fix confusing method name
>>  - Revert "Test if we still (or ever) needed confusing is_old method"
>>    
>>    This reverts commit 5fcaef551d3286bd3e5eae485ac11c5b15ce7ed8.
>>  - Test if we still (or ever) needed confusing is_old method
>
> src/hotspot/share/gc/shenandoah/shenandoahHeap.hpp line 606:
> 
>> 604:   inline bool is_in_young(const void* p) const;
>> 605:   inline bool is_in_old(const void* p) const;
>> 606:   inline bool is_not_in_active_young_collection(oop obj) const;
> 
> Needs a single line documentation comment, given its not very natural/intuitive semantics.

Added a comment.

-------------

PR Review Comment: https://git.openjdk.org/shenandoah/pull/517#discussion_r1806775858


More information about the shenandoah-dev mailing list