git webrev is extremely silent

Jaikiran Pai jai.forums2013 at
Thu Mar 19 02:56:15 UTC 2020

I have just started using the skara CLI tools to generate patches for
the jdk repositories. I am used to using the (original) webrev. When
using the original webrev, you see a bunch of "activity" that gets
logged on the screen and it finally writes out the patch where the
webrev changeset is generated.

However, when I run the "git webrev" command (sometimes with additional
options), it just silently returns. The first few times I tried it, I
thought it wasn't really working. It's only when I looked for directory
listing of potential places, where it might have generated the webrevs,
did I realize that the webrev was being generated successfully and it's
just that the git webrev command it way too silent and doesn't generate
any messages.

Adding a final summary, after the command executes successfully,
including the location where the webrev was generated would help, IMO.
Would this be considered a reasonable enhancement?


More information about the skara-dev mailing list