RFR: 1903: Verify User's repository access when processing backport command [v3]

Zhao Song zsong at openjdk.org
Tue May 9 22:46:26 UTC 2023

On Tue, 9 May 2023 22:39:50 GMT, Erik Joelsson <erikj at openjdk.org> wrote:

>> Will change the name to `checkWriteAccess`. Thanks!
> Thinking some more on this, I think it should be something like `canCreatePullRequest`. Write access implies being able to push to the repo, something we disable through various means most of the time.

Just deleted this whole method. I added a method called 'hasRepoAccess' in 'HostedRepository', I could rename this method to `canCreatePullRequest`


PR Review Comment: https://git.openjdk.org/skara/pull/1516#discussion_r1189196397

More information about the skara-dev mailing list